Chase Paymentech Tampa Service Outage
Incident Report for CardConnect
Resolved
This incident has been resolved.
Posted 5 months ago. Jun 24, 2018 - 20:07 EDT
Investigating
At this time, merchants processing on the Paymentech Tampa platform may be experiencing service outages resulting in transaction time-out responses. We will provide updates from the processor as they become available.
Posted 5 months ago. Jun 24, 2018 - 19:59 EDT
This incident affected: Processors (Chase Paymentech Tampa).