Chase Paymentech Salem Issue
Incident Report for CardConnect
Resolved
This processor issue has been resolved.
Posted Aug 22, 2016 - 12:49 EDT
Investigating
We are investigating intermittent connectivity issues. More details will be provided as they are available.
Posted Aug 18, 2016 - 14:36 EDT
This incident affected: Processors (Chase Paymentech Salem).