TSYS | Funding Delay
Incident Report for CardConnect
Resolved
This incident has been resolved.
Posted Mar 15, 2017 - 08:11 EDT
Identified
Please be advised that a small number of merchant accounts on the TSYS platform experienced settlement delays on the evening of March 13. The issue has been resolved and all delayed funds will be received tomorrow, March 15.
Posted Mar 14, 2017 - 11:15 EDT
This incident affected: Processors (TSYS).