First Data RapidConnect Funding Delays
Incident Report for CardConnect
Resolved
This incident has been resolved.
Posted 10 days ago. Aug 08, 2018 - 17:18 EDT
Identified
Please be advised that merchants may be experiencing funding delays for transactions processed on 8/7/18. Impacted merchants can expect to see funds deposited tomorrow, 8/9/18, after a 24-hour delay. Please note, this issue has no impact on the ability to process transactions.
Posted 10 days ago. Aug 08, 2018 - 11:53 EDT
This incident affected: Processors (First Data RapidConnect).