First Data North | Funding Delay
Incident Report for CardConnect
Resolved
The funding issue on First Data North has been resolved. For those merchants that were affected, any funds that were supposed to be deposited on Thursday, August 4 have been deposited today, August 5.
Posted Aug 05, 2016 - 13:16 EDT
Investigating
First Data North has experienced funding delays today. This means that funds from Wednesday, August 3, may have not yet posted to a merchant's bank account.

First Data is resolving the issue to ensure all funds are deposited tomorrow (August 5). We will provide updates as they become available.
Posted Aug 04, 2016 - 12:34 EDT
This incident affected: Processors (First Data North).