First Data RapidConnect North Timeouts
Incident Report for CardConnect
Postmortem

Please be advised, some merchants may be continuing to experience timeouts when attempting to process transactions. We are looking into the reoccurrence of this issue and will provide updates when they are available.

Posted 20 days ago. Oct 25, 2018 - 16:45 EDT

Resolved
This incident has been resolved.
Posted 20 days ago. Oct 25, 2018 - 16:39 EDT
Investigating
At this time, some merchants may be experiencing timeout responses when attempting to process transactions. We are currently investigating this issue and will provide updates as they become available.
Posted 20 days ago. Oct 25, 2018 - 14:59 EDT
This incident affected: Processors (First Data RapidConnect).