First Data RapidConnect Transaction Failures
Incident Report for CardConnect
Resolved
This issue has been resolved and transactions should be processing normally at this time.

Earlier today, some merchants may have experienced two periods of transaction timeouts and failures:

10:11 a.m. — 10:34 a.m. ET
11:45 a.m. — 12:21 p.m. ET
Posted 3 months ago. May 11, 2018 - 13:41 EDT
Investigating
At this time, merchants may be experiencing transaction timeouts and failures. We are currently investigating this issue and will provide updates as they become available.
Posted 3 months ago. May 11, 2018 - 13:12 EDT
This incident affected: Processors (First Data RapidConnect).