First Data North Funding Delays
Incident Report for CardConnect
Resolved
This incident has been resolved.
Posted 4 months ago. Aug 08, 2018 - 17:18 EDT
Investigating
At this time, some merchants may have experienced funding delays for transactions processed on 8/7/18. Please note, this issue has no impact on the ability to process transactions. We are investigating this issue and will provide updates as they become available.
Posted 4 months ago. Aug 08, 2018 - 11:13 EDT
This incident affected: Processors (First Data North).