TSYS and First Data Omaha | Funding Delay
Incident Report for CardConnect
Resolved
This incident has been resolved.
Posted Mar 23, 2017 - 09:18 EDT
Update
In addition to the previously reported TSYS funding delay, a small group of merchant accounts on the First Data Omaha platform also experienced a funding delay on the evening of March 21. For these merchants, the issue has been resolved and the funds will be deposited normally after a 24-hour delay.
Posted Mar 22, 2017 - 16:12 EDT
Monitoring
A small group of merchant accounts on the TSYS platform experienced settlement delays on the evening of March 21. For those merchants, the issue has been resolved and the funds will be deposited normally after a 24-hour delay.
Posted Mar 22, 2017 - 12:08 EDT
This incident affected: Processors (First Data Omaha).