First Data RapidConnect Timeouts
Incident Report for CardConnect
Resolved
This incident has been resolved.
Posted 14 days ago. Oct 31, 2018 - 17:52 EDT
Investigating
At this time, some merchants may be experiencing timeout responses when attempting to process transactions. We are currently investigating this issue and will provide updates as they become available.
Posted 14 days ago. Oct 31, 2018 - 17:29 EDT
This incident affected: Processors (First Data RapidConnect).