Funding Delays (First Data North-RapidConnect)
Incident Report for CardConnect
Resolved
This incident has been resolved.
Posted 6 months ago. Apr 30, 2018 - 12:09 EDT
Identified
At this time, some merchants may be experiencing funding delays for batches that were settled on Wednesday, April 25. Funding will be received after a one-day delay. We are continuing to investigate this issue and will provide updates as they become available.
Posted 6 months ago. Apr 26, 2018 - 11:24 EDT