Phone Connectivity Issues
Incident Report for CardConnect
Resolved
This incident has been resolved.
Posted Jan 31, 2023 - 15:26 EST
Monitoring
Phone connectivity has been restored. We are continuing to monitor the incident.
Posted Jan 31, 2023 - 14:26 EST
Investigating
We are experiencing phone connectivity issues that are impacting our Partner Solutions and Merchant IVR phone queues. We are currently investigating the issue.
Posted Jan 31, 2023 - 12:55 EST
This incident affected: Phone Support.