Power Outage
Incident Report for CardConnect
Resolved
This afternoon's power outage was due to a nearby gas main leak and has since been resolved.
Posted Dec 03, 2019 - 16:37 EST
Investigating
Please be advised our King of Prussia facility is experiencing a full power outage, resulting in phone and internet connectivity issues. We are working with our service provider to implement a resolution as soon as possible. This issue is not impacting merchant processing capabilities.
Posted Dec 03, 2019 - 14:44 EST