First Data North Funding Delay
Incident Report for CardConnect
Resolved
This incident has been resolved.
Posted 3 months ago. Feb 15, 2019 - 09:24 EST
Monitoring
Please be advised some businesses processing on the First Data North platform may be experiencing funding delays for transactions processed on Tuesday, February 12 and Wednesday, February 13. As a result, those impacted will be funded within 24 - 48 hours.
Posted 3 months ago. Feb 14, 2019 - 12:17 EST
This incident affected: Processors (First Data North).