Transaction Declines
Incident Report for CardConnect
Resolved
The issue has been resolved.
Posted 26 days ago. Nov 14, 2017 - 14:34 EST
Investigating
A group of merchants may be experiencing declines on the CardConnect Gateway. This issue is currently being investigated; we will provide updates as soon as they are available.
Posted 26 days ago. Nov 14, 2017 - 14:01 EST
This incident affected: CardConnect Gateway.