Funding Delays | Partial Impact to First Data RapidConnect Merchants
Incident Report for CardConnect
Resolved
This incident has been resolved.
Posted 8 days ago. Aug 10, 2018 - 17:49 EDT
Investigating
Please be advised that a group of merchants may have experienced funding delays for transactions that were processed on 8/9/18. Impacted merchants can expect to see funds deposited tomorrow, 8/11/18, after a 24-hour delay. Please note, this issue has no impact on the ability to process transactions.
Posted 8 days ago. Aug 10, 2018 - 11:41 EDT
This incident affected: Processors (First Data RapidConnect).