TSYS | Funding Delay
Incident Report for CardConnect
Resolved
This incident has been resolved.
Posted Mar 16, 2017 - 09:41 EDT
Monitoring
A group of merchant accounts on the TSYS platform experienced settlement delays on the evening of March 14. For those merchants, the issue has been resolved and the funds will be deposited normally after a 24-hour delay.
Posted Mar 15, 2017 - 10:20 EDT