First Data North | Funding Delay
Incident Report for CardConnect
Resolved
This incident has been resolved.
Posted Jul 08, 2016 - 04:05 EDT
Identified
A group of merchant accounts on the First Data North platform experienced a settlement delay the evening of July 6. This means that the funds that would have been deposited the morning of July 7, will instead be deposited July 8.
Posted Jul 06, 2016 - 11:05 EDT