Funding Delay - 05/26

Incident Report for CardConnect

Resolved

This incident has been resolved.
Posted May 27, 2026 - 13:16 EDT

Monitoring

A fix has been implemented and we are monitoring results. All merchant funding should complete by tomorrow morning.
Posted May 26, 2026 - 11:29 EDT

Identified

Please be advised, we have identified a funding delay which may affect batches settled between 05/22-05/25. This issue is currently under review.

Please note, this has no impact on the ability to process transactions.
Posted May 26, 2026 - 10:22 EDT
This incident affected: Processors (First Data North, First Data RapidConnect).