Cardpointe Integrated Terminal Disruption

Incident Report for CardConnect

Resolved

This incident has been resolved.
Posted Jun 18, 2025 - 10:03 EDT

Investigating

We are investigating a terminal disruption which may be impacting your
business. We are currently working to resolve this issue.
Posted Jun 17, 2025 - 18:18 EDT
This incident affected: CardPointe Retail Terminal.