Cardpointe Integrated Terminal Service Disruption

Incident Report for CardConnect

Resolved

This incident has been resolved.
Posted Jul 28, 2025 - 09:51 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jul 26, 2025 - 15:09 EDT

Identified

We are investigating a Cardpointe Integrated Terminal Service disruption which may be impacting your
business. We are currently working to resolve this issue. Terminals should reconnect automatically, however, if this does not occur, please power cycle your device to restore service.
Posted Jul 26, 2025 - 15:08 EDT
This incident affected: CardPointe Integrated Payments (CardPointe Integrated Terminal).