Clover Cardpointe Integrated Terminal Disruption

Incident Report for CardConnect

Identified

The issue has been identified and a fix is being implemented.
Posted May 14, 2025 - 18:50 EDT

Investigating

We are investigating a Clover Cardpointe Integrated Terminal disruption which may be impacting your
business. We are currently working to resolve this issue.
Posted May 14, 2025 - 17:49 EDT
This incident affects: CardPointe Integrated Payments (CardPointe Integrated Terminal (Clover)).