CoPilot Email Disruption
Incident Report for CardConnect
Resolved
This incident has been resolved.
Posted May 06, 2020 - 11:06 EDT
Identified
Emails originating from CoPilot (including merchant application emails) are currently delayed. We are currently working to resolve this issue. All queued emails will be sent, please do not attempt to resend as this will cause the recipients to be receive multiple copies.
Posted May 06, 2020 - 10:01 EDT
This incident affected: CoPilot.