CardPointe Integrated Terminal Service Disruption

Incident Report for CardConnect

Resolved

This incident has been resolved.
Posted Mar 26, 2025 - 08:49 EDT

Monitoring

A fix has been implemented we are monitoring results. If you are still having issues with your terminal please manually power cycle the device.
Posted Mar 25, 2025 - 16:48 EDT

Identified

We are investigating a disruption with CardPointe Integrated Terminals which may be impacting your
business. We are currently working to resolve this issue.
Posted Mar 25, 2025 - 16:29 EDT
This incident affected: CardPointe Integrated Payments (CardPointe Integrated Terminal).