TSYS Service Disruption
Incident Report for CardConnect
Resolved
This incident has been resolved.
Posted Jun 02, 2020 - 13:59 EDT
Update
We are continuing to investigate this issue.
Posted Jun 02, 2020 - 12:28 EDT
Investigating
We are currently investigating this issue.
Posted Jun 02, 2020 - 12:26 EDT
This incident affected: Processors (TSYS).