Fiserv ACH Boarding Issue

Incident Report for CardConnect

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Nov 25, 2025 - 13:39 EST

Investigating

We've identified an issue with Fiserv ACH on-boarding. Some merchants may experience a delay in account boarding for this product. Merchants currently registered should not experience any issues processing.
Posted Nov 25, 2025 - 13:36 EST
This incident affects: Processors (ACH Payment Services by Fiserv).