BluePay 03/19/2024 2am CST First Data North Settlement Issue
Incident Report for CardConnect
Resolved
The First Data North settlement issue has been fully resolved. All outstanding transactions have been settled.
Posted Mar 20, 2024 - 09:56 EDT
Monitoring
Reversal of the 03/19/2024 2am CST First Data North settlements has been completed. We are monitoring settlements to verify that all outstanding transactions settle.
Posted Mar 19, 2024 - 22:56 EDT
Identified
The failed 3/19/2024 2am CST settlements are being reversed so that the transactions will settle tonight in the 3/20/2024 2am CST settlement.
Posted Mar 19, 2024 - 22:45 EDT
Investigating
We are currently investigating an issue with the 03/19/2024 2am CST First Data North settlement. Settlements at other times or on other processing platforms were not affected by this issue.
Posted Mar 19, 2024 - 12:18 EDT
This incident affected: BluePay Gateway.