BluePay Gateway Recurring Billing Issue

Incident Report for CardConnect

Resolved

This incident has been resolved. Recurring billing schedules scheduled between 12:00am and 09:17am CST were delayed and have all been executed. Recurring billing has been operating normally since the issue correction.
Posted Jan 15, 2026 - 15:22 EST

Update

All past due recurring billing schedules have been executed.
Posted Jan 15, 2026 - 11:53 EST

Monitoring

A fix has been implemented. The recurring system is currently executing the past due recurring billing schedules.
Posted Jan 15, 2026 - 10:28 EST

Investigating

We are currently investigating an issue that is preventing the BluePay Gateway's recurring billing system from executing recurring billing schedules. There is no impact on non-recurring transaction processing or creation of new recurring billing schedules.
Posted Jan 15, 2026 - 09:44 EST
This incident affected: BluePay Gateway.