Card Pointe Retail Terminal Disruption

Incident Report for CardConnect

Update

We are continuing to monitor feedback on this issue. If you are experiencing connectivity issues, please contact your Internet Service Provider to review. Our support resources are available to assist with any additional concerns.
Posted May 16, 2025 - 11:33 EDT

Update

We are continuing to monitor for any further issues.
Posted May 16, 2025 - 11:17 EDT

Monitoring

We are continuing to monitor feedback on this issue. If you are experiencing connectivity issues, please contact your Internet Service Provider to review. Our support resources are available to assist with any additional concerns.
Posted May 16, 2025 - 11:16 EDT

Investigating

We are investigating a Card Pointe Retail Terminal disruption which may be impacting your
business. We are currently working to resolve this issue.
Posted May 15, 2025 - 14:51 EDT
This incident affects: CardPointe Retail Terminal.