Cardpointe Integrated Terminal Disruption

Incident Report for CardConnect

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 10:00 EST

Monitoring

A fix has been implemented, we are monitoring the results. If your device is unable to reconnect, please power cycle the device to restore connectivity.
Posted Mar 02, 2026 - 16:57 EST

Identified

We have identified a CardPointe Integrated Terminal service disruption which may be impacting your business. Terminals should reconnect automatically. If your device is unable to reconnect, please power cycle the device to restore connectivity.
Posted Mar 02, 2026 - 16:04 EST
This incident affected: CardPointe Integrated Payments (CardPointe Integrated Terminal).